Security Tweets by @jimconnolly

“ If you use Office for Mac, you need to update it.

A new, critical security patch has been issued.”

Jim Connolly Twitter

See what's Trending Now for @jimconnolly

See All Trending »
x
Jim Connolly

Follow @jimconnolly on Twitter